Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

______________
12" White Stickers
______________
BallOfSpray $5 Donation
______________
BallOfSpray $10 Donation

perfect pass help

DGravelleDGravelle Posts: 26 Baller
Hi I was hoping i could get a little help/insight into my perfect pass. If I have it in wakeboard mode the system will work properly but when in slalom mode it will beep like it does when the boat starts to take over control of the speed but goes right on past the speed you have set. and never really stopping just keeps going like you are running it with the system turned off. thanks for any input

Comments

  • Bill22Bill22 Posts: 1,664 Mega Baller
    I don't know what it is but did it ever work in slalom?

    Maybe it's a problem with the RPM cable? It probably is using the paddle wheel for wakeboard. If you have classic PP in slalom it controls off of RPM.

    Run the boat and look at the display for a steady RPM. It should display with PP on or off.
  • Orlando76Orlando76 Posts: 1,118 ★★★Triple Panda Award Recipient ★★★
    Are you using a smart timer? If so unplug it and report back.
  • Fast351Fast351 Posts: 207 Baller
    Have all the baselines been set? Is this a new problem or is this a new install/new to you boat?
    Mike van Meeteren
  • Justin_CJustin_C Posts: 226 Baller
    edited July 2016
    Stargazer or classic? If it's Stargazer, I'd reset the system and run the calibration to make sure that your rpm is set right.
  • DGravelleDGravelle Posts: 26 Baller
    boat is new to me last season has always been this way since i have had it but I am pretty sure that slalom mode has worked in the past because it has peoples names and speeds set in the display @Justin_C I'm guessing it's pp classic because it doesn't say stargazer or 6.4 in the display module but it's not really my area of expertise @Orlando76 I do not believe that there is a smart timer, (not sure how to tell lol)
  • DGravelleDGravelle Posts: 26 Baller
    I should say the boat is a 2006 centurion t5
  • Fast351Fast351 Posts: 207 Baller
    It takes a while with a phone with a GPS speedo on it, but I would reset the box and set it up from scratch. I bought a boat that was used for trick skiing and for the life of me I couldn't get the slalom mode to behave decent. Reset it, reset all the baselines and paddle wheel factors for slalom mode, and now it's very accurate. Probably took me about an hour on a nice calm morning to get it all set up. Worth every minute and gallon of gas burned.
    Mike van Meeteren
  • DWDW Posts: 2,091 Mega Baller
    @DGravelle : Have you downloaded the material from the Perfect Pass website, there are not only several manuals that will walk you through set up and troubleshooting along with some video clips that may also be of use. The Perfect Pass gang is also very helpful on the phone or even via email.
  • AndreAndre Posts: 1,262 Mega Baller
    Had problems recently with 6.5 ,Digital Pro ,one line display.
    Aaron at Perfect Pass had me disconnect the paddle wheel saying that with older systems like mine when the paddle wheel goes bad ,it affect the master module...
    It worked on mine.
    Good luck!
  • Orlando76Orlando76 Posts: 1,118 ★★★Triple Panda Award Recipient ★★★
    You'll see a box about the size of a deck of cards under the dash area, typically left side of boat on the floor, gray, says smart timer. Also look on the module box and you'll see 2 locations for a smart timer to be plugged in, if nothing's plugged in.... Obviously not the issue. Keep in mind only jump and slalom modes use smart timers, but not necessary. Is your display a single line or multi line? It'll also give the version id when its first powered up. Aaron with PP has been helpful for me and Gary has been super helpful and quick. I like calling them, a human answers the phone, usually Carol.
    Andre
Sign In or Register to comment.