Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

______________
12" White Stickers
______________
BallOfSpray $5 Donation
______________
BallOfSpray $10 Donation

Perfect pass screen fading out

Monkstr6100Monkstr6100 Posts: 108 Baller
So on my perfect pass pro 6.5ng I am starting to more and more have issues with the screen fading out on it. I have been told its VERY common on this generation of screen and perfect pass agreed that it is/was a very known issue. Now here is the biggest problem. Perfect pass says they used to make an upgraded replacement gauge, but stop a year or so ago, and now my ONLY option is to UPGRADE for low cost of just under 800 cause they ONLY make stargazer based stuff now? Anyone have any tips for making my current gauge work better. It is caused by humidity, so only have issues in the early AM sets or when its just damp out in general. An hour in the sun and its good to go. Also, everything still works, its just the display goes away. Thanks in advance, Zach J
THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ

Comments

  • Chef23Chef23 Posts: 6,060 Mega Baller
    I have tha problem with my multi line display. Sorry I don’t have a good solution for you.
    Mark Shaffer
  • Bill22Bill22 Posts: 1,764 Mega Baller
    I have an old rev. 6.5 gauge but I am only selling it as a package with a PP classic master module. I will PM you more info.
  • Monkstr6100Monkstr6100 Posts: 108 Baller
    @Chef23 I read someplace about a guy opening his up and then sealing it some how. But can't seem to find that now. And another place that said that perfect pass has a little fix for it but the guy there that I talked to didn't seen to wanna say or didn't know. Always been a huge fan of them, great customer service usually, but this all shocked me. Mine is a 2006, so not like it should be some way out dated device. Especially with so many people going to ZO I would have expected more from PP.
    THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ
  • Monkstr6100Monkstr6100 Posts: 108 Baller
    I may try this stuff as well. Found in another forum to open it up and apply this to the electronics. Waterproofer for electrical strip boards.
    THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ
  • Chef23Chef23 Posts: 6,060 Mega Baller
    @Monkstr6100 if you figure it out let me know. My PP system is about 12 years old and I have upgraded to stargazer but I would rather not buy a new display.
    Mark Shaffer
  • JmoskiJmoski Posts: 363 Solid Baller
    The upgrade is well worth it IMHO, you get a much easier to use interface, gps based control, course mapping, etc.

    I had the same issue with my 2006 PP gauge, so happy I switched.
    jhughesReggieO
  • Fast351Fast351 Posts: 269 Baller
    Had this issue with my 2007 211. I had my gauge replaced under warranty, but exactly the same as you. Gauge would not be visible if humid. PP would work fine.

    I would disassemble the gauge, get it REALLY dry, then conformal coat the board. That should stop the issue.
    Mike van Meeteren
    Monkstr6100
  • wtrskier197wtrskier197 Posts: 22 Baller

    @Monkstr6100 wondering if you were able to open up gauge and seal it up? I've had the same issue for 3 years on an 06 and not really wanting to dish out $800 for an upgrade even though it would be nice.
  • Monkstr6100Monkstr6100 Posts: 108 Baller
    I have not opened up the gauge yet. It is in winter storage till the spring. I do plan to do it when I bring it back home. Will for sure update you all on it when I do. And @wtrskier197 that is exactly how mine is as well.
    THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ
  • Monkstr6100Monkstr6100 Posts: 108 Baller
    Well I opened up the gauge and sprayed the board today. Will install tonight or to borrow and let you know the results. Mine has the chrome bezel. Perfect pass told me I had to cut it off but I was able to bend the bevel part for about 1/3 the bezel and then slide it off.
    THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ
  • Monkstr6100Monkstr6100 Posts: 108 Baller
    So far so good. Re installed and then skied this evening. So far so good, but it was not very humid at all. I sprayed it on, recoated after about 15 min, and then left it out in the sun to dry. Seemed to dry very fast. Hope this works.
    THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ
    wtrskier197
  • wtrskier197wtrskier197 Posts: 22 Baller
    @Monkstr6100 thanks for the update, going to try this fix on mine in a week or two. Boat still hasn't made it out of storage for the year.
    Monkstr6100
  • Same issue on my 07 Avy. I was getting pumped reading this thread because I felt there was going to be a happy ending (solution). I have read prior blogs about the conformal coating but I never came away 100% convinced that it cured the problem. Hopefully, you are still active on this site and can answer my question. Over time did the spray cure the problem permanently, a month, etc.?
  • Monkstr6100Monkstr6100 Posts: 108 Baller
    @midlifecrisis, it for sure improved it but it still is not perfect. It is way less often that it fades out, but it does still happen from time to time. So I think it was worth the effort.
    THE FAMILY THAT PLAYS TOGETHER, STAYS TOGETHER! TEAM JACHOWICZ
  • NZswerverNZswerver Posts: 15 Baller
    I had the same issue, in the end the LCD died completely.
    luckily I sourced a second hand display. Now I have a nice black mastercraft PP display in the middle of a bunch of all white nautique gauges !
  • Thanks for the update Monk. Winter here in Dallas really means no humidity. With no moisture in the air, good time to give it a try. Will update the thread when I put the boat in the water. Dry suits rock!
  • StefanStefan Posts: 127 Baller
    edited February 2020
    I have Stargazer with Zbox. Had a problem with screen turning upside down or going completely blank. After consulting PP I disconnected the depth sounder and that solved the problem. I guess @Monkstr6100 's problem is different though, but my tip might help someone else.
    Andrebikesrus
  • harddockharddock Posts: 184 Baller
    I have a Zero Off that becomes so unreadable (faded) you can't tell if it's on or off. It makes it difficult when you go from a slalom 36 mph mode to a trick 14.5 for a swivel skier. I got another head from someone on Ski it Again but it was while in winter storage and have not yet installed or tried it out.
  • brucethesharkbrucetheshark Posts: 5 New Baller
    edited June 2020
    New to me last week 2006 SN 196 with same problem, cool humid = blank display. PP 6.5ng (my work in auto industry ng=no good). I'm an engineer so I'm going to disassemble, conformal coat, seal LCD to board (from another thread).

    Question: Did PP improve the replacement displays sold on PP.com? Or will it do the same thing eventually?

    4th slalom boat in 30 years, getting used to this. Thanks
  • ISO. Single line MasterCraft white gauge, PP module and/or servo motor/bracket/throttle cable.
  • troslawskitroslawski Posts: 1 New Baller
    Had same issue with 2004 Malibu RLxi Perfect Pass. Moisture was my problem. Removed gauge, tightened screws holding circuit board in place, coated full board with silicone conforming, added a couple silica packets and sealed all unused hols in back of gauge with silicone. Has been good so far.

    Andre
  • brucethesharkbrucetheshark Posts: 5 New Baller
    I used the advice on Malibucrew, maybe yours?
  • brucethesharkbrucetheshark Posts: 5 New Baller
    Well my display is dead now, speed control still works fine, just don't dare try to change a setting. Reading other LCD repair post (not PP related), it seems the likely issue is where the ribbon cable is attached to the LCD glass, which looks to be an adhesive. I can't find any good repair posts that detail how to fix the ribbon cable attachment. Anybody here know anything about this item?
Sign In or Register to comment.