2021Survey ConnellyDV8

Fill out the BallOfSpray reader survey for a chance to win a Connelly DV8

ZO No GPS: Please HELP! — BallOfSpray Water Ski Forum

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

12" White Stickers
BallOfSpray $5 Donation
BallOfSpray $10 Donation

ZO No GPS: Please HELP!

ralral Posts: 1,832 Mega Baller
Yesterday, our 2014 Nautique 200 woke up with the dreadful “No GPS” message. Diagnostics show GPS1 and GPS2 failing, when resetting, they go away but show again both failing after 10 Secs. Disconnected the bsttery, and unplugged and replugged the dashboard unit but no change.


1) Any other suggestions?
2) is the “Garmin GPS 18x 5Hz High-Sensitivity” puck the one to buy
3) Any instructions/suggestion on how to replace the pucks (dismounting and disconnecting old ones, and mounting reconnecting new?

Rodrigo Andai


  • rfarfa Posts: 266 Baller
    From a previous post in 2015...
    "I replaced the two pucks on my '08LXi this summer. Called ZO tech support and after he told me the cost of the new pucks AND without my prompt, told me i should find the same puck for less money elsewhere. Gave me the part # Garmin GPS18x-5Hz. At the time the cheapest I found was at www.gpscity.com...$139.95. Installed them and ZO system worked immediately."
    I recall it was reasonably straightforward to install...may have some instructions in my computer...will check tomorrow
    Rui Afonso
  • LeonLLeonL Posts: 2,432 Crazy Baller
    You gotta put a connector on the new ones @rfa speaks of. They come with just bare wires. That's ok because they have to go thru a small hole under the puck anyway.
    Leon Leonard Stillwater Lake KY - SR Driver SR Judge
  • bigskieridahobigskieridaho Posts: 944 Crazy Baller
    At a tournament we had the same prob Allen with one of the boats and found there were too many courses loaded or loaded the same course over again. Had to go in and delete previous course settings and remap the course. Just a thought.....
  • eleeskieleeski Posts: 3,977 Infinite Pandas
    I ran into a similar problem a while ago. From the darn Russians thread:

    "Push and hold on/off/menu
    When the page comes up, use the arrows to highlight and select SCREEN
    Arrow to DIAGNOSTICS and select
    Select to clear HISTORY
    Press on/off/menu twice to exit back to the normal display (note that this worked perfectly the first time but was a bit weird when I was checking just now - lots of random multiple button pushing, mostly on/off/menu, got me back to the normal screen with a working GPS display)."

    I think the cause was a battery issue. I made sure the battery was fully charged before skiing and survived until I got a new battery.

  • rfarfa Posts: 266 Baller
    @ral, as promised I was able to locate the instructions I used when I replaced the GPS pucks several years ago. Obviously, if the culprit is elsewhere, no need to replace them. Hope this helps. Good luck!
    Rui Afonso
Sign In or Register to comment.