SN200 Linc Blue Screen of Death

LukeBLukeB Posts: 8 New Baller



Anyone have experience with this problem? Started up the linc and was greeted to this screen after the Booting…. It appears to be the boat loader update screen. I found a Murphy guide that shows the blue screen as the boot loader update screen and the black screen as the firmware update screen. I can not seem to get out of this screen. My assumption is that the linc lost / corrupted its boot loader. Anywhere to get the software to reload or any other suggestions? New linc is like 4K for some gages and an interface to ZeroOff. Boat runs fine otherwise.

Comments

  • swc5150swc5150 Posts: 2,561 ★★★Triple Panda Award Recipient ★★★
    That happened the first day out back in day in my bro's '12. Were told to cut power to the link via the switch or disconnecting the battery. We just cut via the switch, re-fired it up and it hasn't happened again to this day.
    Scott Calderwood
  • lakeaustinskierlakeaustinskier Posts: 387 Solid Baller
    This happened to us and after a lot of diagnosing it was a loose connection. Check everything and make sure its tight.
    Ted Thomson, Austin Texas, Aquaplex
    Jody_Seal
  • LukeBLukeB Posts: 8 New Baller
    Thanks. Tried the power cut at the switch but keeps coming back to this screen. Will check all the connections.
  • jpwhitjpwhit Posts: 133 Baller
    Another possible cause of the issue.

    You hold the bottom left button when the boat is powered on to bring up this boot loader screen. It's used to install new firmware. If that bottom left button sticks, you'll have the symptom you describe. Try pressing that bottom left button a few times and see if it feels normal. If this is what's causing your issue, pressing it a few times may break it free.

    swc5150
  • mlangemlange Posts: 234 Baller
    If you message your email address I can send you a PDF w/ the update instructions.

    I also have the firmware for a 2012 and 2013 that I can send you. I've switched back-n-forth playing with both the Mapple Icon firmware and the regular firmware for the fun of it and it's real simple to do. Nautique will be nice enough to provide the firmware if you need it for another year. Just need to email them.
    LukeB
  • LukeBLukeB Posts: 8 New Baller
    Thanks for all the advice. Will give the suggests a go.

    @mlange - check your PM
  • LukeBLukeB Posts: 8 New Baller
    Fixed. At least for now. Got the boot loader and firmware from a dealer and reloaded the system. Hope this helps someone else in the future.
    DavidN
Sign In or Register to comment.