2012 Mastercraft will not start

oldmanskieroldmanskier Posts: 181 Solid Baller
Club boat is a 2012 Mastercraft with 5.7 ILMOR Engine with 2022 hours.
I was pulling a skier and boat started acting like it was running out of gas.
Skier dropped and I was able to idle to dock but boat quit as I got to dock.
I put 5 gallons of gas in.
NOTE: Since our gas gauge does not work we are never sure how much gas is in boat.
I tried to start boat but it would not fire at all.
Gave it a shot of starting fluid in breather and boat still would not fire.
We have a club member that used to be a PCM tech and he checked it out for fuel issues but does not think it is a fuel issue.
He thinks it is a electric or electronic computer issue.
He does not have software for ILMORE 5.7 so not much else he can do to diagnose the problem.
Before taking it to a dealer for this I was wondering if anyone else had this type of issue with a 5.7 ILMOR and if so were you able to resolve your issue without taking to a dealer.
Any information will be appreciated.
Thanks
oldmanskier Tom Smothers.

Comments

  • jpwhitjpwhit Posts: 133 Baller
    If it won't fire using starting fluid, then it's almost certainly an ignition system issue. Have you checked if you have spark? If not, start with replacing the distributor cap and rotor button. It's a pretty common issue on these 5.7L engine.

    It's also pretty common for the ears on the distributor where the screws that hold the distributor screw in to break off. So common that a simple repair solution exists so you don't have to replace the whole distributor.

    https://www.amazon.com/gp/product/B00BQAJNWO/ref=ppx_yo_dt_b_asin_title_o03_s01?ie=UTF8&psc=1
    rodecon
  • ScottScottScottScott Posts: 1,230 Mega Baller
    edited August 31
    Check alternator/battery. They seem to need good voltage to fire (more than needed to crank.) I have left battery switch on to the point the voltage had dropped enough I was worried it wouldn't crank. It did crank, but wouldn't fire. We have a backup battery....installed and it fired right up. Since you were running when you 1st noticed symptom, that would point more toward alternator. But a dead battery could still possibly cause enough drain while running, even with a good alternator. I guess in your current situation, test battery/or charge it up and give a try, or put in another battery you know is good.
  • LeonLLeonL Posts: 2,619 Crazy Baller
    edited August 31
    If it hasn't been replaced recently, as @jpwhit said, I'd replace the cap and rotor. That is a common problem.
    Stupid question, but I suppose it cranks?
    Leon Leonard Stillwater Lake KY - SR Driver SR Judge
  • UWSkierUWSkier Posts: 1,805 Mega Baller
    Does the 2012 have any sort of display screen that might give you a hint? I believe Malibu and CC were using screens for diagnostic at that point.
    boats are like girlfriends you love them however there is another one around the corner - bananaron, July 21, 2020
  • eyepeelereyepeeler Posts: 214 Baller
    Did you run it completely out of gas? That can ruin the fuel pump.
    Matt Dillon
  • oldmanskieroldmanskier Posts: 181 Solid Baller
    Thanks for all the information. Electronic Parts ordered to hopefully fix the issue.
    Note answer to questions above:
    Our 2012 Mastercraft does not have a display screen of any type.
    Boat cranks but does not fire.
    Not for sure if boat ran out of gas or not due to possible electronic issues.
    Fuel pump appears to be functioning ok.
    Thanks again for all the suggestions given in post.
    oldmanskier Tom Smothers
  • buechsrbuechsr Posts: 149 Baller
    It can take many key up cycles to reprime the whole fuel system. Did you test the pressure on the fuel rail on key up?

    I have a diacom (the handheld version) I could send you to use. I have no experience with Ilmor, but would assume that diacom is the requisite diagnostic language. I don't know if I have an Ilmor harness. If you want to ask your PCM tech friend which one it requires or take a picture I'll see if I have it or not.
    bigtex2011
  • oldmanskieroldmanskier Posts: 181 Solid Baller
    buechsr: Fuel system was checked out by our club member that was a former PCM tech. Not for sure what all he did as I was not at the lake when he did his checking. He said all was functioning on fuel system. Hopefully our parts will be in today or tomorrow and we will see if that fixes the issue. Thanks for your input and offer on harness.
  • oldmanskieroldmanskier Posts: 181 Solid Baller
    Installed the following new parts on our 2012 MC. Coil, cap and button. Boat is up and running. Thanks for all the great suggestions to resolve our boat issue.
    Tom Smothers.
  • LeonLLeonL Posts: 2,619 Crazy Baller
    Hang on to the old coil. That likely wasn't the problem.
    Leon Leonard Stillwater Lake KY - SR Driver SR Judge
Sign In or Register to comment.