2018 Prostar Zero Off issue, need troubleshooting help

ztarumztarum Posts: 5
Yesterday the family was pumped to get our boat in at Dividing Creek, NJ for the first local course skiing of the year.

Unfortunately excitement quickly turned to disappointment when I realized that zero off was not working. It was working fine at the end of last season, but now doesn't seem to be even loading. Here are the symptoms:

1) Speed setting stuck at 10 mph for all events (but won’t actually control at 10 when turned on) and can’t be changed on the screen or by buttons.

2) Zero satellites found.

3) Diagnostics shows no active or logged errors but says “ZO did not initialize. Try restarting system” in red at the bottom of that screen. I tried multiple restarts from the battery switch with no change.

4) I also noticed that on Software Version screen and on the Diagnostics screen the "ZO Serial Number" and "ZO Software Version" are both blank. I assume these numbers are usually displayed when everything is working as it should?

What should I try next to troubleshoot? Any local techs or contacts that I could reach out to? I'm in Southern NJ, across the river from Philadelphia. Any help would be appreciated.
Tagged:

Comments

  • BbrandauBbrandau Posts: 45 Baller
    check all wiring ... Would bet the wiring between the brain and the display has come loose or corroded ... Also make sure the battery is fresh. I've seen some dumb things with a bad battery.
  • Jody_SealJody_Seal Posts: 3,832 Mega Baller
    look 7nder your dash and make sure the back has not fallen out of the dongle. and make sure its is properly secured in its fixture as well as oriented correct. make sure all deutsch connections in line with the zo system are completely engaged and clipped in.
    ground check as well as any power positive/ neg sources checked.
    Hobby Boats can be expensive when the hobbyist is limited on their own skill and expertise.


  • ztarumztarum Posts: 5
    I plan to dig in tonight and check all of the wiring. No apparent battery issues at this point (good voltage, engine cranked strong, etc.), but I'll try a swap if I can't find anything else.
  • RAWSkiRAWSki Posts: 969 Mega Baller
    Sounds like wiring-connections most likely--- does the screen control all other functions properly?
  • ztarumztarum Posts: 5
    edited May 2
    Yes, it sure seems to. I didn't test everything while I had it out, but I definitely used it to turn the seat heaters on. It also seemed to navigate between screens fine and all the touch features worked except the speed setting adjustment.
  • RAWSkiRAWSki Posts: 969 Mega Baller
    We had a similar problem on an 18 PS
    The lower 1/5th of the screen lost touch input ability almost everything worked but you couldnt map a course or select pull type
  • ztarumztarum Posts: 5
    I think I found the issue. The board inside the 3E Black Box has a burnt area.
  • Jody_SealJody_Seal Posts: 3,832 Mega Baller
    had the back come unglued??
    Hobby Boats can be expensive when the hobbyist is limited on their own skill and expertise.


  • ztarumztarum Posts: 5
    Yes. It wasn’t completely separated though, just cracked open about 1/3 of the way around. Looks to have been over tightened to the bulkhead which put some undue stress on the cover breaking the seal. That said, the box has a vent/drain hole anyway so the breached seal probably wasn’t a factor.

    I’m wondering if anyone has a pin diagram for the plug? I should probably test grounds and supply power in case the fried board was a symptom of some other fault.
  • MastercrafterMastercrafter Posts: 339 Crazy Baller
    edited May 3
    .
  • LarsLars Posts: 231 Baller
    @mastercrafter I would be interested in that, [email protected]

    Thanks!
Sign In or Register to comment.