Overheating MC

jayskijayski Posts: 1,171 Mega Baller
Friend has a '19 6L Mastercraft and religiously overheats between sets. First set runs perfectly fine, drive it back to the dock, it sits for 10 min shut off, restart and by the time it idles to the end of the lake, maybe 30 sec temps are climbing into high 200's...almost like it gets air locked or something, increasing revs (without driving) brings it back down and then is perfectly fine till the next time...always happens between first and second set, sporadic from there on

Any ideas to fix???

Comments

  • MISkierMISkier Posts: 3,463 Mega Baller
    Did it ever shred an impeller previously? If so, remove hoses and start looking for debris from that which may be impeding water flow.
    The worst slalom equipment I own is between my ears.
  • marknmarkn Posts: 529 Mega Baller
    Sure you have checked the usual suspects; impeller, plugged strainer or strainer tight and not sucking air. Also may want to check temp sensor to be certain temp reading is accurate. The fact that increased revs brings down temp, it sounds like lack of flow...impeller or sucking air. Good luck.
    eyepeeler
  • MISkierMISkier Posts: 3,463 Mega Baller
    One other thing: has the boat been run extensively in muddy water, etc.? Over time, a lot of mud in the engine will harden like concrete and block water flow, which may be overcome by higher revs finally pushing enough through the narrowed channels. If is gets bad enough, you get hot cylinders and melting pistons.
    The worst slalom equipment I own is between my ears.
  • MastercrafterMastercrafter Posts: 390 Crazy Baller
    Sounds like impeller, water pump gasket/o-ring, or air leak in raw water intake. Check all your connections starting at thru-hull intake, trans cooler, water pump.

    The PRV previously mentioned fails in an open state, allowing water to flow through the exhaust without being pushed thru engine. Get the brass one.

    How old is your impeller? I’ve had impellers that appear good, fail to work.

    I was watching a 2018 5.7 with computer for a few passes this weekend, and I was at 165 down the lake, and 175 at idle between passes. 170 degree thermostat.
  • jayskijayski Posts: 1,171 Mega Baller
    Thanks all, but I think @ColeGiacopuzzi has the answer...same issue, seemed to cure it...will get him to order one and see
    ColeGiacopuzzi
  • bigtex2011bigtex2011 Posts: 719 Mega Baller
    or just get a malibu
    jayski
  • jayskijayski Posts: 1,171 Mega Baller
    @bigtex2011 I'll pass that on lol
    MastercrafterDragoLars
  • boscomanboscoman Posts: 20 New Baller
    ColeGiacopuzzi, where is this valve located...back of engine, correct? toward the stern? I don't see it on my ilmor 6.0 mc x14v
  • ColeGiacopuzziColeGiacopuzzi Posts: 539 Open or Level 9 Skier
    @boscoman I don't think that's the same engine, so yours might not have it. The newer 6.0L is called the MPI I think. If yours does have it; it would be right on top towards the back of the motor. Two hoses come from each side and between them is the valve.
  • MastercrafterMastercrafter Posts: 390 Crazy Baller
    On the 5.7, here’s the valve location and update kit PN



    MISkierchrislandyDacon62Andre
Sign In or Register to comment.